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Введение

 
В настоящее время существует множество графических редакторов и программ геомет-

рического моделирования. Компания Autodesk – один из ведущих производителей систем
автоматизированного проектирования и программного обеспечения для конструкторов,
дизайнеров, архитекторов. Это крупнейший в мире поставщик программного обеспечения и
услуг для промышленного и гражданского строительства, машиностроения, геоинформатики,
цифровых средств передачи информации и беспроводной связи, обслуживающий 7 000 000
пользователей.

Система AutoCAD, разработанная этой компанией, является лидирующей в мире плат-
формой программного обеспечения систем автоматизированного проектирования (САПР),
предназначенной для профессионалов, которым требуется воплощать свои творческие
замыслы в реальные динамические проекты.

AutoCAD – программа с богатой и во многом уникальной историей. Впервые она увидела
свет в 1982 году под именем MicroCAD. Первая версия AutoCAD ознаменовала начало насто-
ящей революции в автоматизированном проектировании. Сегодня AutoCAD переводится на
18 языков, ее используют в своей работе миллионы проектировщиков во всем мире на про-
цессорах в тысячи раз мощнее тех, которые были установлены на первых персональных ком-
пьютерах.

AutoCAD является постоянно развивающейся базовой средой проектирования, каждая
новая версия которой наследует все лучшее от предыдущих и направлена на решение следую-
щих основных задач: повышение производительности и эффективности работы пользователей;
обеспечение многократного использования имеющихся наработок; беспрепятственное сотруд-
ничество пользователей при проектировании; адаптация AutoCAD к индивидуальным потреб-
ностям разработчиков объектно-ориентированных задач.

Залог успеха Autodesk – мировое признание AutoCAD в качестве стандарта де-факто для
разработки продуктов и комплектующих, а также для документации.

Используя свою стратегию, направленную на помощь заказчикам в создании, органи-
зации и распространении цифровых конструкторских данных и в решении серьезных биз-
нес-проблем, Autodesk предлагает наиболее полный комплект интегрированных программ-
ных инструментов двумерного и трехмерного конструирования, что позволяет создавать более
качественные продукты, ускорять вывод изделий на рынок и добиваться максимальной нагляд-
ности проектов и наиболее эффективного сотрудничества.

Благодаря выпуску AutoCAD 2009 компания Autodesk предлагает архитекторам, дизай-
нерам, инженерам и проектировщикам новый инструмент для еще более полного воплощения
их идей в реальность.
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От издательства

 
Ваши замечания, предложения и вопросы отправляйте по адресу электронной почты

dgurski@minsk.piter.com (издательство «Питер», компьютерная редакция).
Мы будем рады узнать ваше мнение!
На сайте издательства http://www.piter.com вы найдете подробную информацию о наших

книгах.
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Глава 1

AutoCAD 2009. Общие сведения
 
 

Требования к системе
 

AutoCAD может работать как в автономном режиме, так и в локальной сети. Для эффек-
тивной работы AutoCAD 2009 под управлением операционной системы Windows необходимы
следующие программные и аппаратные средства:

□ процессор Intel® Pentium® IV;
□ операционные системы: Microsoft® Windows® XP Professional или Home Edition (пакет

обновлений SP1 или SP2), Windows XP Tablet PC Edition (SP2) или Windows 2000 (SP3
или SP4). Рекомендуется устанавливать и эксплуатировать AutoCAD либо на операционной
системе, локализованной на одном языке с программой, либо на англоязычной версии одной
из перечисленных систем;

□ Microsoft® Internet Explorer 6.0 (пакет обновлений SP1 или более поздний);
□ 512 Мбайт оперативной памяти;
□ монитор VGA с разрешением не менее 1024 х 768 и поддержкой режима true color;
□ 750 Мбайт свободного места на жестком диске для установки;
□ привод компакт-дисков: любой (только для установки программы).
Требования к системе при использовании AutoCAD 2009 для концептуального проекти-

рования:
□ процессор Intel® с тактовой частотой 3,0 ГГц и выше;
□ Windows XP Professional (пакет обновлений SP2);
□ не менее 2 Гбайт оперативной памяти;
□ 2 Гбайт свободного места на жестком диске, не считая места, необходимого для уста-

новки программы;
□ монитор с минимальным разрешением 1280 х 1024 и поддержкой режима true color;
□ графический адаптер класса рабочих станций, снабженный не менее 128 Мбайт памяти

и поддерживающий технологию OpenGL.
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Запуск системы AutoCAD

 
Запуск AutoCAD осуществляется следующими способами:
□ на Панели задач выберите из меню Start ► Programs ► Autodesk ► AutoCAD 2009;
□ на Рабочем столе Windows дважды щелкните на пиктограмме AutoCAD 2009.
При запуске AutoCAD предлагает создать новый неименованный рисунок. Можно либо

начать создавать в нем объекты, либо загрузить с диска один из уже имеющихся файлов.
При открытии ранее подготовленного рисунка всем системным переменным присваива-

ются значения, которые они имели в ходе последнего сеанса работы с ним. Это происходит
благодаря тому, что переменные сохраняются в файле вместе с рисунком.

Если же вы начинаете работу «с нуля», следует предварительно задать ряд устано-
вок. Обычно это делается автоматически с помощью Мастера подготовки Wizard Description.
AutoCAD позволяет менять установки и в ходе сеанса, если возникает такая необходимость.
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Начало работы

 
После запуска AutoCAD выводится диалоговое окно начала работы Startup (рис. 1.1).
В диалоговом окне Startup пользователю предлагается четыре кнопки, в зависимости от

выбора которых меняется содержимое диалогового окна:

Open a Drawing – для открытия ранее созданного чертежа;

Start from Scratch – для создания чертежа, где устанавливаются только единицы измере-
ния в области Default Settings: британские (футы и дюймы) или метрические (миллиметры);

Use a Template – для создания чертежа по шаблону – документу, установки которого
используются как основа для нового рисунка;

Use a Wizard – вызов Мастера для установки параметров нового чертежа.

Рис. 1.1. Диалоговое окно начала работы
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Вызов справочной системы

 

В любой момент работы с AutoCAD вы можете получить доступ к электронной докумен-
тации по программе. Для этого необходимо выбрать в падающем меню пункт Help. Альтерна-
тивный вариант – нажать клавишу F1 на функциональном блоке клавиатуры, ввести символ?
в командную строку или щелкнуть на пиктограмме со значком вопроса на стандартной панели
инструментов.
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Открытие рисунков

 
Программа AutoCAD по умолчанию записывает внутреннее представление рисунка в

файл с расширением DWG.
AutoCAD предлагает многооконную среду проектирования Multiple Design Environment

(MDE), которая допускает одновременное открытие нескольких чертежей.

Открыть существующий рисунок можно с помощью команды OPEN, которая вызывается
из падающего меню File ► Open… или щелчком на пиктограмме Open…Ctrl+О на стандартной
панели инструментов.

После обращения к команде OPEN на экране AutoCAD появляется диалоговое окно
выбора файла Select File (рис. 1.2). Здесь можно выбрать имя файла из списка или ввести это
название в поле File name:

Рис. 1.2. Диалоговое окно выбора файла

При выделении в списке одного из файлов в области Preview появляется соответствую-
щий образец рисунка. Нажатие кнопки Views выводит список, изменяя параметры которого
пользователь может выбрать форму представления файлов, предлагаемых для открытия: спи-
сок, таблицу, образцы.

Для открытия рисунка можно дважды щелкнуть на имени соответствующего файла в
Проводнике Windows, что приведет к автоматическому запуску AutoCAD. Если же в системе
уже ведется сеанс работы в AutoCAD, то рисунок откроется в нем.
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Рисунки, созданные в AutoCAD любой предшествующей версии, открываются как любой
документ версии 2009 и автоматически преобразуются в новый формат.
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Создание рисунков

 

Создать новый рисунок позволяет команда NEW, вызываемая из падающего меню File
► New… или щелчком на пиктограмме QNew на стандартной панели инструментов.

После запуска команды необходимые настройки параметров рабочей среды AutoCAD
производятся в диалоговом окне создания нового рисунка Create New Drawing – рис. 1.3.

Рис. 1.3. Диалоговое окно создания нового рисунка

В AutoCAD имеется так называемый Мастер подготовки Wizard – служебное средство
для создания нового рисунка.

Для вызова Мастера подготовки необходимо в диалоговом окне Create New Drawing
щелкнуть на пиктограмме Use a Wizard.

Мастер быстрой подготовки QuickSetup позволяет задать для нового рисунка единицы
измерения Units и область рисования Area. Поддерживаются следующие типы единиц для
рисования и вычерчивания: десятичные – Decimal, инженерные – Engineering, архитектурные
– Architectural, дробные – Fractional, научные – Scientific.

Указывая ширину Width и длину Length области рисования, пользователь тем самым
задает граничные пределы рисунка, так называемые лимиты. Именно лимитами определяется
размер чертежа, впоследствии выводимого на плоттер.

Мастер детальной подготовки Advanced Setup позволяет задать для нового рисунка тип
линейных единиц измерения Units и способ измерения углов Angle, указать начало отсчета
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угла Angle Measure и направление измерения угла Angle Direction, определить границы области
рисунка Area.

Любая из установок, произведенных в начале рисования, в дальнейшем может быть изме-
нена.
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Определение границ рисунка

 
Команда LIMITS позволяет установить границы текущего рисунка. Она вызывается из

падающего меню Format ► Drawing Limits.
Границы рисунка – это пара двумерных точек в мировой системе координат: координаты

левого нижнего и правого верхнего углов, определяющие прямоугольную область. По оси Z
границы не устанавливаются.

Запросы команды LIMITS:
Reset Model space limits: – переустановка лимитов пространства модели
Specify lower left corner or [ON/OFF] <current>: – левый нижний угол
Specify upper right corner <current>: – правый верхний угол
Лимиты должны полностью охватывать полномасштабную модель.
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Определение параметров сетки

 
Сеткой называется упорядоченная последовательность точек, покрывающих область

рисунка в пределах лимитов. Работа в режиме GRID подобна наложению на рисунок листа
бумаги в клетку. Использование сетки помогает выравнивать объекты и оценивать расстояние
между ними. Сетку можно включать и отключать в ходе выполнения других команд. На печать
она не выводится.

Включение сетки и определение ее частоты осуществляется на вкладке Snap and Grid
диалогового окна режимов рисования Drafting Settings (рис. 1.4), которое загружается из пада-
ющего меню TooLs ► Drafting Settings. .. или при выборе пункта настройки Settings… кон-
текстного меню, вызываемого щелчком правой кнопкой мыши на кнопке Grid Display в строке
состояния.

Сетка включается при установке флажка Grid On (F7). В области Grid spacing устанавли-
вается частота горизонтальных и вертикальных делений сетки, то есть шаг сетки по осям X и
Y. Это осуществляется в текстовых полях Grid X spacing: и Grid Y spacing: соответственно. В
поле Major line every: устанавливается шаг основной линии.

При работе с рисунком включать и отключать сетку следует щелчком на кнопке Grid
Display в строке состояния или нажатием функциональной клавиши F7.
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Рис. 1.4. Диалоговое окно определения параметров сетки и шага привязки
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Определение шага привязки

 
В режиме шаговой привязки SNAP курсор может находиться только в определенных

точках согласно установленному значению шага и при этом движется не плавно, а скачкооб-
разно между узлами воображаемой сетки, как бы «прилипая» к ее узлам.

Шаговая привязка обычно используется для точного указания точек с помощью мыши.
Интервал привязки задается отдельно по осям X и Y.

Шаг привязки не обязательно совпадает с частотой сетки. Сетку часто делают достаточно
редкой, используя ее исключительно для наглядности, а шаг привязки устанавливают мень-
шим. Допустимо и обратное: установка большего по сравнению с сеткой шага привязки.

Включение шаговой привязки SNAP и настройка ее параметров осуществляются на
вкладке Snap and Grid диалогового окна режимов рисования Drafting Settings, которое загру-
жается из падающего меню Tools ► Drafting Settings… или при выборе пункта Settings… из кон-
текстного меню, вызываемого щелчком правой кнопкой мыши на кнопке Snap Mode в строке
состояния.

Шаговая привязка включается при установке флажка Snap On (F9). В области Snap
spacing задается шаг привязки по горизонтали и вертикали. Это осуществляется в текстовых
полях Snap X spacing: и Snap Y spacing: соответственно.

Тип привязки устанавливается в области Snap type. Grid snap – шаговая привязка
(Rectangular snap – ортогональная, Isometric snap – изометрическая), PolarSnap – полярная
привязка.

При работе с рисунком включать и отключать шаговую привязку следует щелчком на
кнопке Snap Mode в строке состояния или нажатием функциональной клавиши F9.
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Сохранение рисунков

 

Команда сохранения рисунка QSAVE вызывается из падающего меню File ► Save или
щелчком на пиктограмме Save Ctrl+S на стандартной панели инструментов.

Команды SAVE и SAVEAS предназначены для сохранения рисунка под другим именем.
Команда SAVE может вызываться только из командной строки, а SAVEAS – из падающего
меню File ► Save As.... В обоих случаях имя документа задается в поле File name: диалогового
окна Save Drawing As – рис. 1.5.

Рис. 1.5. Диалоговое окно сохранения рисунка

Предыдущей копии рисунка на диске присваивается расширение BAK вместо DWG. Все
предыдущие BAK-файлы с данным именем удаляются. Обновленный рисунок записывается с
расширением DWG. Если при указании имени файла оказывается, что рисунок с таким назва-
нием уже существует, выдается предупреждение и предоставляется возможность перезаписать
файл или ввести другое имя.
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Получение твердой копии рисунка

 

Перед выводом рисунка на плоттер можно предварительно просмотреть, как он будет
размещаться на листе бумаги. Для этого используется команда предварительного просмотра
PREVIEW, вызываемая из падающего меню File ► Plot Preview или щелчком на пиктограмме
Plot Preview на стандартной панели инструментов.

Все установки вывода рисунка на плоттер осуществляются в диалоговом окне Plot –
Model (рис. 1.6), Это окно загружается командой PLOT, вызываемой из падающего меню File
► Plot… или щелчком на пиктограмме Plot_CtrL+P на стандартной панели инструментов.

Рис. 1.6. Диалоговое окно вывода на печать пространства модели
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Выход из AutoCAD

 
Для выхода из AutoCAD используется команда QUIT, которая вызывается из падающего

меню File ► Exit Ctrl+Q.
Команда позволяет сохранить или проигнорировать сделанные в рисунке изменения и

выйти из AutoCAD. Если все выполненные изменения сохранены, при выходе из программы
не появится никаких дополнительных сообщений. В противном случае на экран будет выве-
дено диалоговое окно AutoCAD, предлагающее пользователю выбор: сохранить изменения,
отказаться от них или продолжить сеанс работы. Если текущему рисунку не было присвоено
имя и вы хотите сохранить рисунок, откроется диалоговое окно Save Drawing As.
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Глава 2

Пользовательский интерфейс AutoCAD
 

На рис. 2.1. показан классический рабочий стол AutoCAD для Windows.

Рис. 2.1. Рабочий стол AutoCAD

В данный рабочий стол включены:
□ падающие меню Menu Browser – меню, появляющееся при щелчке на кнопке A в верх-

нем левом углу окна программы;
□ необязательные панели инструментов: стандартная панель Standard и панель стилей

Styles – верхняя строка окна программы; панель рабочих пространств Workspaces, слоев Layers
и свойств Properties – вторая строка; панель рисования Draw и редактирования Modify –
столбцы слева и справа; инструментальная палитра Tool Palettes – в правой части окна про-
граммы;

□ строка состояния – строка внизу окна программы;
□ окно командных строк – выше строки состояния;
□ графическое поле, занимающее остальную часть рабочего стола.
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Падающие меню

 
Строка падающих меню по умолчанию содержит следующие пункты:
□ File – команды работы с файлами: создание, открытие, сохранение, публикация в

Интернете, печать, экспорт файлов в другие форматы, а также диспетчеры параметров листов,
плоттеров, стилей печати и пр.;

□ Edit – инструменты для редактирования частей графического поля рабочего стола про-
граммы, работы с буфером обмена и пр.;

□ View – управление экраном, зумирование, панорамирование, установка трехмерной
точки зрения, создание видовых экранов и именованных видов, установка визуальных стилей,
тонирование, анимация траектории перемещения, установка необходимых панелей инструмен-
тов;

□ Insert – команды вставки блоков, внешних объектов, объектов других приложений;
□ Format – команды работы со слоями и их инструментами; цветом, типами линий;

управление стилями текста, размеров, мультилиний, таблиц; видом маркера точки; установки
единиц измерения, границ чертежа;

□ Tools – управление рабочими пространствами; палитрами; установка порядка про-
рисовки объектов и получение сведений о них; работа с блоками и их атрибутами; работа
с языком AutoLISP; работа с пользовательской системой координат; настройка стандартов
оформления; управление Мастерами (публикации в Интернете, установки плоттеров, создания
таблиц стилей печати, цветозависимых стилей печати, компоновки листа, создания подшивки,
импорта параметров печати); установка параметров черчения и привязок с помощью диалого-
вых окон и пр.;

□ Draw – команды двумерного и трехмерного рисования;
□ Dimension – команды простановки размеров и управления параметрами размерных

стилей;
□ Modify – команды редактирования элементов чертежа;
□ Window – многооконный режим работы с чертежами;
□ Help – вывод на экран системы гипертекстовых подсказок.
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Панели инструментов

 
Команды AutoCAD на панелях инструментов представлены в виде пиктограмм. Если

задержать указатель мыши на пиктограмме, рядом с ней появляется название соответствую-
щей команды, помещенное в маленький прямоугольник.

Если в правом нижнем углу пиктограммы изображен маленький черный треугольник,
это значит, что она содержит подменю с набором родственных команд. Для вызова подменю
необходимо на некоторое время задержать на пиктограмме указатель мыши, нажав ее левую
кнопку.
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Стандартная панель инструментов

 
Стандартная панель Standard показана на рис. 2.2.

Рис. 2.2. Стандартная панель инструментов

Она содержит следующие инструменты:

QNew – создание нового файла рисунка;

Open… (Ctrl+О) – загрузка существующего файла;

Save (Ctrl+S) – сохранение текущего файла;

Plot… (Ctrl+P) – вывод рисунка на плоттер, принтер или в файл;

Plot Preview – предварительный просмотр чертежа перед выводом на печать, позволяю-
щий увидеть размещение чертежа на листе бумаги;

Publish… – публикация листов чертежа в формате файла Design Web Format (DWF),
загрузка диалогового окна Publish;

3DDWF – экспорт трехмерной модели в формате файла Design Web Format (DWF);

Cut (Ctrl+X) – копирование объектов в буфер обмена с удалением их из рисунка;
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Copy (Ctrl+C) – копирование выбранных элементов чертежа в буфер Windows без удале-
ния их из исходного документа;

Paste (Ctrl+V) – вставка данных из буфера Windows;

Match Properties – копирование свойств заданного объекта другому объекту;

Block Editor – редактирование блоков;

Undo (Ctrl+Z) – отмена последнего действия;

Redo (Ctrl+Y) – восстановление только что отмененного действия;

Pan Realtime – перемещение изображения на текущем видовом экране в режиме реаль-
ного времени;

Zoom Realtime – увеличение или уменьшение видимого размера объектов на текущем
видовом экране в режиме реального времени;

Подменю Zoom – раскрывающийся набор инструментов, в котором можно задать раз-
личные способы увеличения и уменьшения видимого размера объектов на текущем видовом
экране;

Zoom Previous – возврат к показу предыдущего вида;

Properties (Ctrl+1) – загрузка палитры управления свойствами объектов;
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DesignCenter (Ctrl+2) – диалоговый интерфейс, позволяющий быстро находить, просмат-
ривать, вызывать, переносить в текущий рисунок ранее созданные рисунки, управлять вхожде-
ниями блоков, внешними ссылками и другими элементами рисунков, такими как слои, листы
и текстовые стили;

Tool Palettes Window (Ctrl+3) – инструментальные палитры в виде отдельных вкладок
специального окна, которые служат эффективным средством хранения/вставки блоков и штри-
ховки. Палитры могут содержать инструменты, предоставленные сторонними разработчиками;
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Конец ознакомительного фрагмента.

 
Текст предоставлен ООО «ЛитРес».
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мобильного телефона, с платежного терминала, в салоне МТС или Связной, через PayPal,
WebMoney, Яндекс.Деньги, QIWI Кошелек, бонусными картами или другим удобным Вам спо-
собом.
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